1

Closed

CDMI Proxy packages installation not well documented

description

The installation of the CDMI Proxy package should be more documented: http://resources.venus-c.eu/cdmiproxy/docs/intro.html#installation-from-packages
I installed the deb and I could just find the /etc/cdmiproxy and looking in the system dirs I found a cdmipd binary that I supposed was the startup script. From there I got an error:

Traceback (most recent call last):
File "/usr/local/bin/cdmipd", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2707, in <module>
working_set.require(__requires__)
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 686, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 584, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: distribute

If one has a different installation of the dependencies these should be defined somehow (if that is the problem).
Closed Jul 10, 2012 at 10:23 AM by ilja

comments

ilja wrote Mar 20, 2012 at 11:08 AM

Could you please tell me exact OS distro? To assure deb's work there. Ubuntu and Debian versions have somewhat different package names.

danielelezzi wrote Mar 20, 2012 at 6:11 PM

It's a Debian

ilja wrote Jul 10, 2012 at 10:23 AM

This was caused by a missing python-setuptools package. Documentation was updated to include a reference to this.